New Motor - The Mustang Source - Ford Mustang Forums

Notices
Warranty and Service Issue

New Motor

Reply

 
 
 
Old 10/22/18, 05:08 PM
  #1  
Member
Thread Starter
 
Wildcatress's Avatar
 
Join Date: August 6, 2018
Location: California
Posts: 18
Thanked 0 Times in 0 Posts
New Motor

I have a 2014 RW Mustang and just had the motor replaced at under 109,000 miles... My warranty was 100,000 or 6 years... No check engine light or check oil light came on. Just had a new motor put in and now my car has a leak already in the front end.. Could the techs smash something into my radiator when installing the motor... Took it in and waiting for answers from Ford... Very upset with my Mustang... Is anyone else having motor problems with the 3.7L 4V Ti VCT V-6 motor?
Wildcatress is offline  
Reply With Quote
Old 10/23/18, 12:19 PM
  #2  
Member
Thread Starter
 
Wildcatress's Avatar
 
Join Date: August 6, 2018
Location: California
Posts: 18
Thanked 0 Times in 0 Posts
WHEW!!! The front end leak turned out to be the drain plug and seal for the motor... It was defective. And also the reservoir for the radiator fluid had a very slow leak upon inspection... They said no impact caused it... The leak was at the seam.... So waiting for the reservoir to be replaced now and I can have my baby back.
Wildcatress is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jkstang78
Fox Mustangs
4
6/18/12 08:58 PM
94tbird
2005-2009 Mustang
5
3/25/07 05:28 PM
ucdavisboy
Car Care
2
2/10/05 09:24 AM
ucdavisboy
1994-2004 V-6
1
2/6/05 01:57 PM
mustang65
1st and 2nd Generations
0
3/21/04 03:49 PM


Thread Tools
Search this Thread
Quick Reply: New Motor


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.