Notices
2007-2009 Mustang GT/CS California Special

smelling burning

Old 2/7/15, 10:10 PM
  #1  
Member
Thread Starter
 
Join Date: February 7, 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
smelling burning

Hey guys, I'm new here. I have a 2009 v6 4.0 5 speed. I've been having a weird burning smell when I turn off the engine. I went to the store turned the car off. When I tried to restart it would only make a click it would not turn over.
I tried to jump it, still nothing so i push started it and it worked. Took it to the shop they said it was the starter. Of course I let them change it. It started once and would not start again. They said something is stopping power from getting to the stater. Has anyone ever heard of this please help. Thanks in advance.
badass82 is offline  
Old 2/8/15, 06:10 AM
  #2  
Post *****
 
Glenn's Avatar
 
Join Date: August 7, 2006
Location: Las Vegas NV
Posts: 14,479
Received 157 Likes on 142 Posts
I can only assume the shop tested the battery and alt?? If those two are good I would look at the battery cables and make sure all connecting points are clean and tight. How many miles are on the car? Did the shop show you the old starter? I always ask to see the old parts.
Glenn is offline  
Old 2/8/15, 08:13 AM
  #3  
Member
Thread Starter
 
Join Date: February 7, 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
The car has 66xxx miles on it the connections are good. I didn't ask for the old starter. They're saying its a wire that has shorted but I just wanted a sec opinion. Battery cables still look brand new and they're tight.
badass82 is offline  
Old 2/10/15, 12:47 AM
  #4  
Team Mustang Source
 
GottaHaveIt's Avatar
 
Join Date: January 5, 2005
Posts: 11,364
Likes: 0
Received 14 Likes on 14 Posts
Originally Posted by badass82 View Post
The car has 66xxx miles on it the connections are good. I didn't ask for the old starter. They're saying its a wire that has shorted but I just wanted a sec opinion. Battery cables still look brand new and they're tight.
I heard the same story and she had a loose ground doing sorta what you described ford has an oxidization issue & positive cables fall apart.
GottaHaveIt is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
sarnold58
General Mustang Chat
3
6/9/19 02:22 PM
GTPETE
Car Care
8
10/12/15 02:20 PM
Hristofor
1994-2004 V-6
3
9/11/15 12:05 PM
tukatz
Off-Topic Chatter
12
9/8/15 04:33 AM
f1-cobra
Warranty and Service Issues
8
8/1/15 08:02 PM


Thread Tools
Search this Thread
Quick Reply: smelling burning


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.