Radio static when defroster on - The Mustang Source - Ford Mustang Forums


Radio static when defroster on

Reply
 
 
 
Thread Tools Search this Thread
Old 9/11/17, 05:46 AM   #1
Member
Thread Starter
 
Join Date: August 22, 2016
Location: MD
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Radio static when defroster on

In my 2016 Mustang GT, whenever I turn the defroster on, the radio is just static (AM or FM). Any solutions to this?
knahs is offline   Reply With Quote
Join The Mustang Source

Join TheMustangSource.com Today - It's Totally Free!

Are you a Ford Mustang fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford Mustang Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your stang, and have a great time with other Ford Mustang fans. Whether your an old timer or just bought your Mustang you'll find that TheMustangSource.com is a great community to join. Best of all it's totally free!

Join TheMustangSource.com Today! - Click Here JOIN FOR FREE


Old 9/11/17, 09:54 AM   #2
Cobra R Member
 
SpectreH's Avatar
 
Join Date: February 5, 2015
Location: Warner Robins, GA
Posts: 1,950
Thanked 150 Times in 133 Posts
Odd, sounds like a bad ground somewhere. Your 2016 should still be under warranty. A trip to the dealer might be your best bet.
SpectreH is offline   Reply With Quote
Old 9/11/17, 10:18 AM   #3
FR500 Member
 
HOSS429's Avatar
 
Join Date: January 27, 2007
Location: alerbamer
Posts: 3,251
Thanked 55 Times in 47 Posts
.. my corolla does it also .. it may be a normal thing .. though it should`nt be ..
HOSS429 is offline   Reply With Quote
Old 9/13/17, 08:10 PM   #4
Shelby GT350 Member
 
Cavero's Avatar
 
Join Date: February 13, 2006
Posts: 2,110
Thanked 24 Times in 23 Posts
do you know if the antenna is built into the rear window? My wife used to have an old CLK that did and had that problem. I read they were on the same circuit, but had a capacitor to keep electrical impulses from the defroster from feeding back into the antenna. If the capacitor fails, you get a buzz.
Cavero is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -6. The time now is 12:05 AM.


2010, The Mustang Source