Notices
2010-2014 Mustang News on the Previous Generation Mustang

Snapping/popping noise from front of car when stopping 2011 - GT - Auto

Old 7/9/10, 06:26 AM
  #1  
GT Member
Thread Starter
 
Join Date: March 18, 2010
Location: NJ
Posts: 151
Likes: 0
Received 0 Likes on 0 Posts
Snapping/popping noise from front of car when stopping 2011 - GT - Auto

When braking from low speeds I am getting a fairly loud pop or snap sound from the front of the car, it may actually be from the brakes but I am not sure.

I can reproduce it fairly easily in a parking lot as it happens at very low speeds <5mph.

Anyone else hear this?

Last edited by Argetni; 7/9/10 at 09:17 AM.
Argetni is offline  
Old 7/9/10, 08:49 AM
  #2  
Mach 1 Member
 
Join Date: April 22, 2010
Posts: 903
Likes: 0
Received 0 Likes on 0 Posts
Not really noticed anything unusual myself, except that at 1st/2nd in the manual it can slow down in a hurry once you let off the gas.
Lancel is offline  
Old 7/9/10, 12:55 PM
  #3  
Shelby GT350 Member
 
MRGTX's Avatar
 
Join Date: May 18, 2010
Location: CT
Posts: 2,309
Received 13 Likes on 12 Posts
Does the car stop okay? Do you feel a vibration or is it just a noise?

I had something similar in other cars where the brake pads have some small amount of play in their cages on the calipers and eventally they seem to get stuck in place. It's weird that a factory install would have this problem... but it seems to match.

If it's not related to that, I would have the dealership check the brake caliper bolts or suspension bushings. I don't know what else it could be..
MRGTX is offline  
Old 7/9/10, 12:58 PM
  #4  
GT Member
Thread Starter
 
Join Date: March 18, 2010
Location: NJ
Posts: 151
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by MRGTX View Post
Does the car stop okay? Do you feel a vibration or is it just a noise?

I had something similar in other cars where the brake pads have some small amount of play in their cages on the calipers and eventally they seem to get stuck in place. It's weird that a factory install would have this problem... but it seems to match.

If it's not related to that, I would have the dealership check the brake caliper bolts or suspension bushings. I don't know what else it could be..
Yeah it stops fine. It does sound like a pad snapping into place kind of.

I tried two hard stops from 40 but no change.

I just moved the car in the parking lot at work and could not get it to make the sound so it seems like it has to be driven for a bit first to do it.

Maybe I will try some hard stops from 60 or 80 as a "test".
Argetni is offline  
Old 7/9/10, 01:53 PM
  #5  
Cobra R Member
 
tom_vilsack's Avatar
 
Join Date: August 7, 2004
Location: Ladner,Canada
Posts: 1,765
Likes: 0
Received 0 Likes on 0 Posts
if it doesn't go away...i would take in for service...just to be on safe side.

or pull wheels and take a look yourself (if you know what your doing)
tom_vilsack is offline  
Old 7/13/10, 09:24 AM
  #6  
GT Member
Thread Starter
 
Join Date: March 18, 2010
Location: NJ
Posts: 151
Likes: 0
Received 0 Likes on 0 Posts
I now think this is in the suspension and not brake related. Brakes are perfect when slamming them 100 plus to make an exit off the highway.

I notice if I hit the gas hard and make the rear squat at low speeds when I hit the brake and make the front dive I get the sound. I can do it over and over pretty much.

It almost sounds like a spring popping into place or something.
Argetni is offline  
Old 7/13/10, 09:31 AM
  #7  
GT Member
 
dsmdiggler's Avatar
 
Join Date: September 8, 2009
Location: AZ
Posts: 105
Likes: 0
Received 0 Likes on 0 Posts
What you are describing sounds a lot like the "popping" in the suspension of the early s197s. It was always at low speeds as well, and was related to the front strut mounts I believe. Anyone else concur?
dsmdiggler is offline  
Old 7/13/10, 09:37 AM
  #8  
GT Member
Thread Starter
 
Join Date: March 18, 2010
Location: NJ
Posts: 151
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by dsmdiggler View Post
What you are describing sounds a lot like the "popping" in the suspension of the early s197s. It was always at low speeds as well, and was related to the front strut mounts I believe. Anyone else concur?
Yes it does and I have been reading some of those threads, but this is not constant like those were it is only once after rebound and compression.
Argetni is offline  
Old 7/13/10, 09:50 AM
  #9  
GT Member
 
dsmdiggler's Avatar
 
Join Date: September 8, 2009
Location: AZ
Posts: 105
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by Argetni View Post
Yes it does and I have been reading some of those threads, but this is not constant like those were it is only once after rebound and compression.
Right, I think we are describing the same thing. My 05 would make the popping noise at low speeds (Parking lots, wherever I was turning very slow), but sometimes it did it and other times it wouldn't. Either way, find a way you can reproduce the noise and take it in for service. I'm sure they would be happy to work on a new 5.0.
dsmdiggler is offline  
Old 4/25/11, 08:42 AM
  #10  
Member
 
Join Date: March 10, 2011
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
did anyone find out what this problem was, i just started to have this problem happen to me this morning, in my 2011 5.0, with only 1100 miles on it.
mnblk5.0 is offline  
Old 4/25/11, 09:18 PM
  #11  
Member
 
Join Date: September 10, 2010
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
I also have a popping sound, from what feels like under my feet (front lower control arm??) when I go up and down my driveway. Not always... Maybe 30% of the time? Sorta like it pops "into place" when going up the driveway, then back "out" when backing out in the reverse motion... My driveway is the sort that has a sharply-sloped lip that is the same angle regardless of whether it is a driveway entrance or regular sidewalk curbing... so it is rather steep. And it all started after I lowered it. I'll probably replace those control arms with aftermarket ones someday if it gets really annoying.
Hub2011 is offline  
Old 4/26/11, 06:52 PM
  #12  
Member
 
Join Date: March 10, 2011
Posts: 8
Likes: 0
Received 0 Likes on 0 Posts
mine is not lowered, and it makes this sound, i dont think its the brakes, it sounds like a suspension type of thing, only when more aggressive braking it does this.
mnblk5.0 is offline  
Old 4/28/11, 09:25 AM
  #13  
Ford Customer Service Rep
 
FordService's Avatar
 
Join Date: October 25, 2010
Location: Dearborn, MI
Posts: 5,279
Likes: 0
Received 11 Likes on 9 Posts
Hi mnblk5.0 and Hub2011,

My name is Deysha from Ford Customer Service. Have you brought this up to your dealerís attention and have your vehicle diagnosed? If not, please contact your dealer as soon as possible. Also, I would like to see how I can help as well. Please message me with your VIN, mileage, contact info, and dealer.

Deysha
FordService is offline  
Old 5/11/11, 09:37 AM
  #14  
Member
 
bdiederichs's Avatar
 
Join Date: September 12, 2009
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
My 2012 GT is doing this after then then a week off the showroom floor 600 miles on the odo.
the dealer thinks it's the front susension bushings.

I'm taking it in for service in a couple days for them to check it out
bdiederichs is offline  
Old 7/25/11, 06:53 AM
  #15  
Member
 
silentfury's Avatar
 
Join Date: July 25, 2011
Location: NJ
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by bdiederichs View Post
My 2012 GT is doing this after then then a week off the showroom floor 600 miles on the odo.
the dealer thinks it's the front susension bushings.

I'm taking it in for service in a couple days for them to check it out
what was the result of you taking it in? i'm having similar issues on my 2012 GT with <1000 miles and i've already been to the dealership once for them to look it over.
silentfury is offline  
Old 7/25/11, 09:45 AM
  #16  
Bullitt Member
 
flySWA737's Avatar
 
Join Date: October 28, 2010
Location: Palm Beach, FL
Posts: 439
Likes: 0
Received 0 Likes on 0 Posts
My 2006 V6 did this and a TSB was released for the early MY that the upper strut mounts needed to be replaced. Sounds like history is just repeating itself. Probably could just swap out the factory upper strut mounts with GT500 strut mounts or the Steeda HD strut mounts if the dealer cant seem to find the issue.
flySWA737 is offline  
Old 7/25/11, 01:29 PM
  #17  
Member
 
bdiederichs's Avatar
 
Join Date: September 12, 2009
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Originally Posted by silentfury

what was the result of you taking it in? i'm having similar issues on my 2012 GT with <1000 miles and i've already been to the dealership once for them to look it over.
A bad bushing on my front drivers side. took them forever to get the part and replace it
bdiederichs is offline  
Old 7/26/11, 12:31 PM
  #18  
Member
 
rationallo's Avatar
 
Join Date: July 11, 2011
Posts: 16
Likes: 0
Received 0 Likes on 0 Posts
I just had LCAs replaced on a 2012 GT with about 500 miles, there is a TSB but the dealer should take a looksee to confirm noise/TSB.

Read up on this thread.
https://themustangsource.com/f804/se...-11-gt-497368/
rationallo is offline  
Old 7/26/11, 12:57 PM
  #19  
Member
 
silentfury's Avatar
 
Join Date: July 25, 2011
Location: NJ
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
my noise is at slow speeds <10mph when i apply the brakes. it occurs either straight or turning and i notice it most when turning into a parking spot at work. i have not noticed it going over speed bumps or anything similar. and it is a single popping/clicking noise that occurs once when i hit the brakes. if i were to let up and brake again, it would pop/click again.
silentfury is offline  
Old 5/25/19, 07:15 AM
  #20  
Member
 
Join Date: May 25, 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Yes this happened to me, and thought the worst. I couldn't imagine the brakes because the sound felt like a broken end link, tie rod or ball joint, but I pulled the wheels and removed the brake caliper and noticed the brake pads were loaded with black gunk greasy muck on both left and right wheels inside and outside brake pads. I scraped the crud off, and reassembled everything and MAGIC no more creeking, popping "WTF is happening down there?" take a look. Good luck, hopefully you have the same issue and not something worse.
Ginger Pony is offline  

Thread Tools
Search this Thread
Quick Reply: Snapping/popping noise from front of car when stopping 2011 - GT - Auto


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.