Notices
2005-2009 Mustang S197 Discussion & News

'05 V6 Manual - no power to starter

Old 9/21/15, 10:03 AM
  #1  
Member
Thread Starter
 
Join Date: September 21, 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
'05 V6 Manual - no power to starter

Background - son bought a "rebuilt" titled '05 while I was out of town on business - his money.... He took it to his cousin's house this weekend to install an amp and sub's in trunk. After they disconnected the battery to wire in the amp, the car won't start.


We push started it - so it runs - all systems getting power. But when you turn the key to start the car - nothing - not even a click like the battery is low, not ATS lights, nadda.... we don't have a user manual, and I can tell that in the "rebuild" they did some interesting things - horn's aren't hooked up, it is using a Clifford Alarm tweeter as the horn, and none of the O2 sensors were put into the exhaust past the exhaust manifolds (if there were any on the '05's.)
He's really disappointed - any thoughts on what's limiting power to the Starter relay?
Thanks - No Start - Seattle :-)
BigHoss is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
RCooke08GT
2005-2009 Mustang
9
2/19/17 03:03 AM
austin101385
'10-14 Shelby Mustangs
3
10/2/15 01:00 PM
mx5jhb
2005-2009 Mustang
3
9/30/15 04:44 PM
Kalel08
GT
2
9/29/15 03:06 PM


Thread Tools
Search this Thread
Quick Reply: '05 V6 Manual - no power to starter


Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.