Cluster gauges dim!!!!!!!! - The Mustang Source - Ford Mustang Forums

Notices
2005-2009 Mustang S197 Discussion & News

Cluster gauges dim!!!!!!!!

Old 3/14/19, 12:57 PM
  #1  
Member
Thread Starter
 
Pauls02's Avatar
 
Join Date: May 27, 2013
Location: Naples, FL
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Cluster gauges dim!!!!!!!!

I have a 06 Roush that the instrument cluster gauges are dim but but radio time display and all other non Roush dash lights work perfectly and work as should when you use dial to dim and brighten. The white backing on Roush gauges seem like they donít light at all! The red u see in photos do dim and brighten. See photo of them at full strength. Fuses are fine, was thinking headlight rheostat but lights do dim and brighten turning ****. Anyone else have this problem.
Pauls02 is offline  
Old 3/18/19, 09:55 AM
  #2  
Mach 1 Member
 
Join Date: August 28, 2005
Location: Winnipeg Mb. Ca
Posts: 598
Thanks: 0
Thanked 13 Times in 12 Posts
Check the following fuses: in BEC fuse box engine compartment; fuse #44-10amp and fuse #67-30amp. In the SJB right kick panel; fuse #6-5amp and fuse #19-5amp. I think fuse #19-5 amp may be the one causing problems. Check for signs of water intrusion on the SJB.
Lime GT is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
HizliBullet
2010-2014 Mustang
6
8/5/12 11:01 AM
tom_vilsack
Fox Mustangs
8
12/15/10 05:35 PM
OKLACOP
1st and 2nd Generations
3
8/13/07 09:01 AM
HOTLAP
05-09 Interior and Audio Mods
0
10/6/06 06:57 PM
whtmule
2005-2009 Mustang
4
6/26/05 01:33 PM


Thread Tools
Search this Thread
Quick Reply: Cluster gauges dim!!!!!!!!


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.