Go Back   The Mustang Source - Ford Mustang Forums > Mustang by Model Year > 2010-2014 Mustang > Warranty and Service Issue
Sign in using an external account
Register Forgot Password?
Search

Welcome to The Mustang Source!
Welcome to The Mustang Source,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 7/17/12, 04:22 PM   #1
Member
 

Join Date: July 17, 2012
Posts: 7
Front suspension noise on 2012 gt

I purchased a 2012 mustang gt in April 2012. The car just turned 2000 miles on the odometer. On really hot days after driving the car for about 20 minutes I start to hear a small clunk when I accelerate after a stop sign or traffic light. I can also slightly feel it. This usually happens on my way home from work. I have opened the hood a few times after I heard this noise and pushed down on the front of the car and I can hear what sounds like a creaking or grinding noise. It actually sounds like dry rubber rubbing on something. Could this be the Lower control arm tsb issue. I have already brought it to the dealer for it and they said they could not duplicate the noise. I told them they would have to drive the car to get it good and warm and they claim they did while telling me the technician working on my car had to leave early. Well I went for a drive with another tech that was there and we drove for a while, When we got back it started to make that creaking noise just not as loud as usual. The tech told me don't worry that is normal. I am tired of hearing oh that is normal. I don't think front suspension should sound like an old creaking rocking chair.
I also get a ticking noise from the passenger side of the motor which I have been told twice that that noise too is normal. Anyone else experiencing these issues. I paid alot of money for this car but it seems the dealership doesn't really want to address the issues. It also bothers me that ford knew the lcas were bad but continued to use them anyway.
2012CandyRedGT is offline   Reply With Quote
Old 7/18/12, 12:46 PM   #2
Member
 

Join Date: July 17, 2012
Posts: 7
I see there is a ford service representative monitoring this forum...Maybe they could help me escalate this and actually get my car fixed since the dealer seems to not want to fix the problem
2012CandyRedGT is offline   Reply With Quote
Old 7/18/12, 03:48 PM   #3
Member
 

Join Date: July 17, 2012
Posts: 7
Coming home from work today the noises got worse. The car sounded like it wanted to fall apart going over a railroad crossing and pulling in a driveway it creaked and groaned really bad. Has to be the lcas it has all the symptoms. I am ready to give up dealer doesn't seem to care. I might contact ford itself to see If I can get this fixed,
2012CandyRedGT is offline   Reply With Quote
Old 7/19/12, 07:31 AM   #4
Ford Customer Service Rep
 
FordService's Avatar
 
Deysha

Join Date: October 25, 2010
Location: Dearborn, MI
Posts: 4,553
Quote:
Originally Posted by 2012CandyRedGT View Post
I purchased a 2012 mustang gt in April 2012. The car just turned 2000 miles on the odometer. On really hot days after driving the car for about 20 minutes I start to hear a small clunk when I accelerate after a stop sign or traffic light. I can also slightly feel it. This usually happens on my way home from work. I have opened the hood a few times after I heard this noise and pushed down on the front of the car and I can hear what sounds like a creaking or grinding noise. It actually sounds like dry rubber rubbing on something.
I also get a ticking noise from the passenger side of the motor which I have been told twice that that noise too is normal. It also bothers me that ford knew the lcas were bad but continued to use them anyway.
Quote:
Originally Posted by 2012CandyRedGT View Post
I see there is a ford service representative monitoring this forum...Maybe they could help me escalate this and actually get my car fixed since the dealer seems to not want to fix the problem
Hello 2012CandyRedGT,

Welcome to the forum! My name is Deysha with Ford Service. Id like to escalate this for you. Please PM me with your VIN, mileage, full name, best daytime number, and dealer so I can escalate this to the Customer Service Manager for your area.

Deysha
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordMustang @Ford
f: facebook.com/FordMustang facebook.com/Ford
FordService is offline   Reply With Quote
Old 7/23/12, 05:40 PM   #5
Mach 1 Member
 
Nighthawk13's Avatar
 
Phil

Join Date: March 6, 2012
Location: Quebec
Posts: 863
I have the exact same problem and I'm bringing her to the dealer tomorrow.
__________________
Feb. 2014 MOTM
http://imageshack.com/a/img5/6340/k0ei.jpg
2013 GT/CS black with electronics package and 3.55 ordered 2012/02/10, window sticker 2012/03/23 build date: 2012/03/31 delivery date 2012/04/13
2012 Focus SE black with sports package delivered 2011/11/02
2nd TSB clutch pack installed. Now she is worth keeping.
Nighthawk13 is offline   Reply With Quote
Old 7/28/12, 12:58 PM   #6
GT Member
 
Trumpetlon's Avatar
 
Lon

Join Date: August 28, 2011
Location: Phoenix, AZ
Posts: 175
I've had mine in twice, the first time they couldn't duplicate, the second time I took the lead tech out and duplicated it. It was blamed on the front sway bar bushings, greased them and returned. The squeak went away until I got rained on and it's back with a vengeance. I think I'm going to replace the sway bars with something stiffer and see if that works, I'm fed up with the dealer....
__________________
2012 GT Premium, Kona Blue, Stone, 400a, MT82 w/skip shift eliminated, MGW, 3.31, 18X9/10 AM 2010 GT500 255/45 285/40, 55D Rear Springs, Airaid CAI, Bob's Oil Sep, Redline Hood Struts, Pypes 3" X pipe w resonator delete and GT 500 Axle Backs, Blend Mount and Mirror Tap for the Escort 9500i, Barton white shift **** and adapter, V-LEDs blue LED map lights,
Trumpetlon is offline   Reply With Quote
Old 8/15/12, 11:48 PM   #7
Bullitt Member
 

Join Date: May 12, 2011
Posts: 312
I have the same EXACT problem. The front control arms seem to really squeak on hot days after driving the car for about 20 minutes. It started from day 1, it's a 2012 with 9000 miles on it. I brought my car in 3 times and they replaced the front control arms 3 times, no luck.....squeak always comes back, any solutions?
Will3212 is offline   Reply With Quote
Old 8/17/12, 02:55 PM   #8
Member
 
ray

Join Date: August 12, 2012
Location: st.pete florida
Posts: 4
hello same thing 2012 gt 3k miles . took it Monday to the dealer . picked it up they said normal noise .

drove back there today no call . took tech for a ride said it was normal again !! .

I went and drove other car's today before i went in today and there was no noise . when i told the tech that . he then had me go back and we pulled to the service area.

he goes to computer and comes back and said look.. they have a new tbs for this . said we will order part's and will call you .

and hello everyone .
FL_ray_2012gt is offline   Reply With Quote
Old 8/22/12, 01:04 PM   #9
Member
 

Join Date: August 22, 2012
Posts: 19
Hello everyone - I'm a new member of this forum as of today, and unfortunately I'm having the exact same problem! I purchased my 2013 GT on 7/12/12, and the problem first started 5 days later on 7/17! The noise really is unbearable - I'm driving a brand new car and it sounds horrible. I took it back to the dealership and they acknowledged that it is an existing control arm problem with certain Mustangs (see TSB 11-7-8) and that the only "fix" was to replace the control arms. However, they told me that the "fix" was only temporary because they were going to replace an allegedly defective part with a "new" defective part. I went ahead and had the dealership replace the control arms on 7/25, and the problem appeared to be resolved. But, lo and behold, the problem has already returned (as the dealership service advisor said it would)...less than 30 days after having the control arms replaced.

To all of you out there with the same problem, what has your experience been? Has the problem with your car been identified (anything other than control arms/bushings?)? Has the problem been resolved by your dealership or by Ford?

Thanks!
MATTYHOU is offline   Reply With Quote
Old 8/24/12, 10:21 AM   #10
Ford Customer Service Rep
 
FordService's Avatar
 
Deysha

Join Date: October 25, 2010
Location: Dearborn, MI
Posts: 4,553
Quote:
Originally Posted by Will3212 View Post
I have the same EXACT problem. The front control arms seem to really squeak on hot days after driving the car for about 20 minutes. It started from day 1, it's a 2012 with 9000 miles on it. I brought my car in 3 times and they replaced the front control arms 3 times, no luck.....squeak always comes back, any solutions?
Quote:
Originally Posted by FL_ray_2012gt View Post
hello same thing 2012 gt 3k miles . took it Monday to the dealer . picked it up they said normal noise .
drove back there today no call . took tech for a ride said it was normal again !! .
I went and drove other car's today before i went in today and there was no noise . when i told the tech that . he then had me go back and we pulled to the service area.
he goes to computer and comes back and said look.. they have a new tbs for this . said we will order part's and will call you .
and hello everyone .
Quote:
Originally Posted by MATTYHOU View Post
Hello everyone - I'm a new member of this forum as of today, and unfortunately I'm having the exact same problem! I purchased my 2013 GT on 7/12/12, and the problem first started 5 days later on 7/17! The noise really is unbearable - I'm driving a brand new car and it sounds horrible. I took it back to the dealership and they acknowledged that it is an existing control arm problem with certain Mustangs (see TSB 11-7-8) and that the only "fix" was to replace the control arms. However, they told me that the "fix" was only temporary because they were going to replace an allegedly defective part with a "new" defective part. I went ahead and had the dealership replace the control arms on 7/25, and the problem appeared to be resolved. But, lo and behold, the problem has already returned (as the dealership service advisor said it would)...less than 30 days after having the control arms replaced.
To all of you out there with the same problem, what has your experience been? Has the problem with your car been identified (anything other than control arms/bushings?)? Has the problem been resolved by your dealership or by Ford?
Thanks!
Hello guys,

Please PM me with your dealer, VIN, mileage, full name, and best daytime number so I can escalate this to the Customer Service Manager for your area.

Deysha
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordMustang @Ford
f: facebook.com/FordMustang facebook.com/Ford
FordService is offline   Reply With Quote
Old 8/24/12, 10:27 AM   #11
Member
 

Join Date: August 22, 2012
Posts: 19
Thanks, Deysha. I sent you a PM with my info already.
MATTYHOU is offline   Reply With Quote
Old 8/24/12, 01:42 PM   #12
Xar
Mach 1 Member
 
Xar's Avatar
 
Chris

Join Date: June 10, 2012
Location: Southern Oregon
Posts: 693
I don't have a 12, I have a 13 ---- today I went over some speed bumps and I get the groan, sounds like driver side front... I'm taking it in for an oil change tomorrow so I'll have them look at this too... *SIGH*
__________________
-- 2013 GT Premium - GHIG - 19" Bright Machined Aluminum Wheels - Comfort Package - Spoiler Delete - 3.55
-Mods: OTT Black Stripes - SF Giants cue ball shift **** - Boss 302 Quad Exhaust - GT500 Axel Backs
-Next Mods: MGW Shifter - RTR Rims - CAI and custom tune
Xar is offline   Reply With Quote
Old 8/24/12, 02:45 PM   #13
Bullitt Member
 
redneb's Avatar
 
Brian

Join Date: January 7, 2012
Location: NJ
Posts: 220
My 12 GT is going in for this on 8 /28. Wish me luck.
__________________
2012 GT Prem Performance White Convertible 6MT, AMR 19 X 8.5 charcoal GT500 style wheels, Boss coil covers
redneb is offline   Reply With Quote
Old 8/24/12, 11:03 PM   #14
Member
 
ray

Join Date: August 12, 2012
Location: st.pete florida
Posts: 4
pm sent !
FL_ray_2012gt is offline   Reply With Quote
Old 8/27/12, 09:49 AM   #15
Ford Customer Service Rep
 
FordService's Avatar
 
Deysha

Join Date: October 25, 2010
Location: Dearborn, MI
Posts: 4,553
Quote:
Originally Posted by MATTYHOU View Post
Thanks, Deysha. I sent you a PM with my info already.
Quote:
Originally Posted by FL_ray_2012gt View Post
pm sent !
Thank you, guys. Ill get back to you as soon as possible.

Quote:
Originally Posted by Xar View Post
I don't have a 12, I have a 13 ---- today I went over some speed bumps and I get the groan, sounds like driver side front... I'm taking it in for an oil change tomorrow so I'll have them look at this too... *SIGH*
Quote:
Originally Posted by redneb View Post
My 12 GT is going in for this on 8 /28. Wish me luck.
Hey Xar and redneb,

PM me with your info as well, so I can escalate yours.

Deysha
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordMustang @Ford
f: facebook.com/FordMustang facebook.com/Ford
FordService is offline   Reply With Quote
Old 8/30/12, 10:39 AM   #16
Member
 
ray

Join Date: August 12, 2012
Location: st.pete florida
Posts: 4
dropped off my car yesterday . put new arms on . seems ok for now .
FL_ray_2012gt is offline   Reply With Quote
Old 8/30/12, 11:12 AM   #17
Member
 

Join Date: August 22, 2012
Posts: 19
Quote:
Originally Posted by FL_ray_2012gt View Post
dropped off my car yesterday . put new arms on . seems ok for now .
Good luck on yours!

Mine's in today for 2nd round of replacements...
MATTYHOU is offline   Reply With Quote
Old 8/30/12, 11:19 PM   #18
Mach 1 Member
 
mikeyt03's Avatar
 

Join Date: July 5, 2012
Posts: 779
I have the same problem over speed bumps, but only when I take them pretty fast. It just sounds like a squeaky bed. In my car it's really not that bad. I do hear some squeaking when I turn my steering wheel fully and have to maneuver around parking lots. For a 38k car, I guess you could say its embarrassing. I think I will wait to have them replace the control arms until they have an actual non-defective fix for it. Now I'm scared to lower my car because I'm sure my dealer will tell me it's because of my suspension. It might be smart to have it documented now I guess, before I lower my car.
mikeyt03 is offline   Reply With Quote
Old 8/31/12, 08:24 PM   #19
Bullitt Member
 
redneb's Avatar
 
Brian

Join Date: January 7, 2012
Location: NJ
Posts: 220
Quote:
Originally Posted by mikeyt03
I have the same problem over speed bumps, but only when I take them pretty fast. It just sounds like a squeaky bed. In my car it's really not that bad. I do hear some squeaking when I turn my steering wheel fully and have to maneuver around parking lots. For a 38k car, I guess you could say its embarrassing. I think I will wait to have them replace the control arms until they have an actual non-defective fix for it. Now I'm scared to lower my car because I'm sure my dealer will tell me it's because of my suspension. It might be smart to have it documented now I guess, before I lower my car.
Probably a good idea to wait to hear what the Ford fix is before you do any suspension mods.
__________________
2012 GT Prem Performance White Convertible 6MT, AMR 19 X 8.5 charcoal GT500 style wheels, Boss coil covers
redneb is offline   Reply With Quote
Old 9/5/12, 08:20 PM   #20
Bullitt Member
 

Join Date: May 12, 2011
Posts: 312
I took my car in for this issue for the 4th repair attempt in a year this morning. The manager told me Ford has new updated control arms with new part numbers. He ordered them and said they'll be released the end of this month. He'll call me when the new parts get in
Will3212 is offline   Reply With Quote
Old 9/5/12, 08:20 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

Sponsors



 

MotM Winners
December 2012 MotM Winner November 2012 MotM Winner September 2012 MotM Winner August 2012 MotM Winner

All times are GMT -6. The time now is 02:53 PM.


Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.