Heated/Cooled Seats Not Working - The Mustang Source - Ford Mustang Forums

Notices
GT

Heated/Cooled Seats Not Working

Reply

 
 
 
Old 1/26/18, 08:49 AM
  #1  
Member
Thread Starter
 
Join Date: January 26, 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Heated/Cooled Seats Not Working

2016 with heated/cooled seats. The seats have worked fine until last week when they stopped working on both sides (driver & passenger). Control panel lights still work. Tried replacing the fuse and still nothing. Any suggestions?
ncsu9244 is offline  
Reply With Quote
Old 1/26/18, 10:11 AM
  #2  
Shelby GT350 Member
 
SpectreH's Avatar
 
Join Date: February 5, 2015
Location: Norman, OK
Posts: 2,278
Thanked 240 Times in 215 Posts
As much as I hate going to the dealer, if it is still under warranty, I'd have them fix it.
SpectreH is offline  
Reply With Quote
Old 1/26/18, 01:53 PM
  #3  
GT Member
 
Join Date: February 6, 2015
Posts: 143
Thanks: 0
Thanked 2 Times in 2 Posts
If the heat works but not the cool, check if your Mustang air conditioner puts out cold air. Mustangs (including mine) are having a problem where the evaporator core is failing.
15BluStang is offline  
Reply With Quote
Old 1/26/18, 02:03 PM
  #4  
Member
Thread Starter
 
Join Date: January 26, 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Neither is working. No heating/no cooling on either side. And out of warranty.
ncsu9244 is offline  
Reply With Quote
Old 2/17/18, 03:35 PM
  #5  
Cobra R Member
 
wanted33's Avatar
 
Join Date: February 26, 2012
Location: Down south in Dixie
Posts: 1,974
Thanked 142 Times in 127 Posts
Check the fuse my friend. With both being out, that could be your culprit. I hope it's that simple for you.
wanted33 is offline  
Reply With Quote
Old 12/5/18, 09:59 AM
  #6  
Member
 
Join Date: December 5, 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Originally Posted by ncsu9244 View Post
2016 with heated/cooled seats. The seats have worked fine until last week when they stopped working on both sides (driver & passenger). Control panel lights still work. Tried replacing the fuse and still nothing. Any suggestions?
did you ever figure out what caused the problem?? Having the same issue now ..thankss
SHADY240 is offline  
Reply With Quote
 
 
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ncsu9244
Ecoboost
2
2/3/18 04:48 AM


Thread Tools
Search this Thread
Quick Reply: Heated/Cooled Seats Not Working


Featured Sponsors

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.