Notices
Warranty and Service Issue

Electrical issues on 2014 mustang

Old 9/24/15, 08:38 PM
  #1  
Member
Thread Starter
 
Join Date: September 24, 2015
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Electrical issues on 2014 mustang

I have a 2014 with around 46k miles on it. Sometimes when I start my car, nothing electronic works. There is a tire pressure sensor error and the brake light is on. The fuel gauge, spedometer, a/c, radio, lights, etc. are all non-functional. The engine still runs and the car is driveable. It happens occasionally. When it does, I have to wait several minutes for everything to become operational again. Any explanation of this issue or help would be greatly appreciated.
captainEO is offline  
Old 9/24/15, 08:42 PM
  #2  
Shelby GT350 Member
 
SpectreH's Avatar
 
Join Date: February 5, 2015
Location: Norman, OK
Posts: 2,328
Received 287 Likes on 258 Posts
Have the battery checked. When they get weak, weird stuff happens while the depleted battery is being charged.
SpectreH is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
jc46002003
Warranty and Service Issue
70
4/15/16 03:00 PM
apial
'10-14 V6 Modifications
4
9/6/15 10:40 AM
BentCopper
Introductions
8
7/21/15 08:35 PM
densue4150
Introductions
3
7/21/15 12:01 PM
dmichaels
2010-2014 Mustang
23
7/18/15 08:32 AM


Thread Tools
Search this Thread
Quick Reply: Electrical issues on 2014 mustang


Featured Sponsors

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.