Notices
General Mustang Chat Not Tech or Model Year Specific

New battery on car but no power at all

Old 3/15/19, 08:55 AM
  #1  
Member
Thread Starter
 
Join Date: March 14, 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
New battery on car but no power at all

Hi every one im new on the site and i recently bought a 2000 mustang gt 3.8 v6 with a 5spd manual.
I replaced the battery with cables and terminals but when i try to start it nothing came on. So the i jump start it and it turns on fine but it haves a houling sound coming from the maf sensor, and it goes away when i disconnect the iac valve. Everything is fine after 15 min it starts to rough idle and a bunch of detonation happens idle goes up and down the it just go down untill it stalls . Even if i press the gas pedal it detonates badly and turns off if anyone that can help me or guide me on what the problem might be. Pls and thank you

2000 mustang gt 3.8 5spd manual
Marquez3.8gt is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Marquez3.8gt
Testing, Help, Site Feedback and Suggestions
2
3/14/19 05:48 PM
Skandocious
Warranty and Service Issue
5
2/6/17 01:25 PM
tucsondivots
Warranty and Service Issue
1
9/23/16 09:10 PM
PATAN
Warranty and Service Issues
11
2/6/07 05:09 PM


Thread Tools
Search this Thread
Quick Reply: New battery on car but no power at all


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.