Go Back   The Mustang Source - Ford Mustang Forums > Mustang by Model Year > 2005-2009 Mustang > Warranty and Service Issues
Sign in using an external account
Register Forgot Password?
Search

Warranty and Service Issues All Warrenty related problems, issues, TSBs, and anything else revolving around the service departments.

Welcome to The Mustang Source!
Welcome to The Mustang Source,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 6/6/08, 7:08 AM   #1
Bullitt Member
 
mustangdaren's Avatar
 
Daren

Join Date: May 21, 2005
Location: Hildebran, NC
Posts: 259
Mustang GT, Mustang Saleen
E-brake light, TCS off light, TPS light

The E-brake light, TCS off light, TPS light all came on at the same time. This is on a friends 07 Mustang V6 convertible. Any idea what condition might cause this?
__________________
1989 Mustang LX Coupe, Medium Shadow Blue
Mods: FMS 302 longblock, Vortech S-trim, Snow Boost Cooler, Saleen GFX, Eibach Sportline, and too much more to list.
2007 Mustang GT, Windveil Blue
Mods: C&L Street CAI, SCT X-Cal 2 tuned by Brenspeed, FRPP/Borla Stinger exhaust, Eibach Pro-kit, American Racing Razor 20x9 wheels, Nitto P265/35/20 tires, aftermarket audio-Sony, Scosche, Hifonics, Mb Quart
mustangdaren is offline   Reply With Quote
Old 6/11/08, 12:18 PM   #2
GT Member
 
tr6nut's Avatar
 
Hugh

Join Date: January 11, 2007
Location: Northern VA, USA
Posts: 143
2007 Mustang GT Coupe
When this happened on my 07 GT, it was a defective brake fluid level sensor in the master cylinder
__________________
2007 Mustang GT
Grabber Orange, 5-speed (my Open Track car)
Too many mods to list

2011 Mustang V-6 Conv.
Candy Red Metallic, 6-speed Auto (wifes' DD)
Stock
tr6nut is offline   Reply With Quote
Old 12/20/08, 4:17 AM   #3
Member
 
Bill

Join Date: January 19, 2005
Location: Georgia
Posts: 25
2005 GT
My 05-GT just stared doing the same thing. All alarms go off too. Very annoying. I'll check the sensor.
05mealready is offline   Reply With Quote
Old 12/21/08, 8:32 AM   #4
GT Member
 
tr6nut's Avatar
 
Hugh

Join Date: January 11, 2007
Location: Northern VA, USA
Posts: 143
2007 Mustang GT Coupe
An easy way to check it is to unplug the sensor (its on the side of the master cylinder) when the symptoms appear. If the symptoms go away when the sensor is unplugged, then the sensor is bad.
__________________
2007 Mustang GT
Grabber Orange, 5-speed (my Open Track car)
Too many mods to list

2011 Mustang V-6 Conv.
Candy Red Metallic, 6-speed Auto (wifes' DD)
Stock
tr6nut is offline   Reply With Quote
Old 12/21/08, 8:32 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

Sponsors



 

MotM Winners
December 2012 MotM Winner November 2012 MotM Winner September 2012 MotM Winner August 2012 MotM Winner

All times are GMT -6. The time now is 6:00 PM.


Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.