Go Back   The Mustang Source - Ford Mustang Forums > Mustang by Model Year > 2005-2009 Mustang
Sign in using an external account
Register Forgot Password?
Search

2005-2009 Mustang
S197 Discussion & News

Welcome to The Mustang Source!
Welcome to The Mustang Source,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12/16/08, 6:38 PM   #1
Member
 

Join Date: October 16, 2008
Location: Massachusetts
Posts: 17
Front end noise

I recently brought my 07 GT to the dealer to have the TSB performed on the front strut mount replacement because my car was exhibiting noises on bumpy roads. Kinda sounds like something is loose. Well after the replacements went in the noise is still there. Is anyone else having this problem or is your front end quiet?
ptaylor_9849 is offline   Reply With Quote
Old 12/17/08, 6:34 AM   #2
Cobra Member
 
Doogie's Avatar
 
Doug

Join Date: October 15, 2008
Location: Brew City
Posts: 1,370
07 GT Convertible
Images: 2
Garage
It might help to include any mods you might have installed, especially with the front suspension.
__________________
E-force 455RWHP/433RWTQ, Foose hood, CDC convertible bar & windscreen, Saleen Heritage rear bumper, CDC billet grills, Bullitt dash & steering wheel, GTAs, Bullitt suspension, TCI shifter, PI converter, SHR billet interior, PH Driveshaft, GT500 pumps, Afco HE, GT500 Brembos
Doogie is offline   Reply With Quote
Old 12/17/08, 7:12 AM   #3
Member
 

Join Date: October 16, 2008
Location: Massachusetts
Posts: 17
I have not done ANYTHING to the suspension other than this service bulletin which didn't work. http://www.stangnet.com/images/stori...s/07-18-02.pdf

Last edited by ptaylor_9849; 12/17/08 at 7:21 AM.
ptaylor_9849 is offline   Reply With Quote
Old 12/17/08, 7:12 PM   #4
Bullitt Member
 
ksguy73's Avatar
 

Join Date: May 16, 2006
Location: Las Vegas
Posts: 292
2010 GB GT Premium
Garage
Mine always makes a rattling noise from the front, like something is loose, when going over the washboards going onto base. (I don't know what they're called but they're the grated bumps that make alot of noise when going over them) I have never worried about it since that is the only time it does it and they are pretty rough no matter how slow you go. Other than that it is quiet. I did have a squeeking/squaking noise from the front several months ago and it turned out to be bad struts from the factory but nothing ever sounded loose with that.
__________________
2010 Grabber Blue GT Premium, 5sp, HID's.
Mods: FRPP 1.5" springs, FRPP dampers, 20x9/20x10 Shelby CS69 wheels, slotted/drilled rotors, ceramic pads, 255/35-285/30 Nitto tires, FRPP Stinger exhaust, FRPP shaker intake, Roush facia, Roush front/side splitters, Roush grill, custom hood stripes, tail panel blackout, GT500 spoiler, GT500 diffuser, tinted side marker/tail lights, Grabber Pony shift **** and air bag decals, interior welting, Scott Drake engine caps and battery hold down, strut tower covers.

Previous Stangs: 95 Laser Red GTS, 08 Vista Blue GT/CS
ksguy73 is offline   Reply With Quote
Old 12/17/08, 7:12 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

Sponsors



 

MotM Winners
December 2012 MotM Winner November 2012 MotM Winner September 2012 MotM Winner August 2012 MotM Winner

All times are GMT -6. The time now is 1:54 AM.


Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.