Go Back   The Mustang Source - Ford Mustang Forums > Mustang by Model Year > SN95 Mustang > 1994-2004 V-8
Sign in using an external account
Register Forgot Password?
Search

1994-2004 V-8 GT, GTS, Bullitt, Mach 1, and Cobra

Welcome to The Mustang Source!
Welcome to The Mustang Source,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 8/18/11, 12:05 AM   #1
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
Mustang GT problems

Ok so, I recently bought a 2003 mustang GT and know the car is acting up, when I try to crank it, it will turn on but cut right off, this happens around 3 times then it's fine, it feels like lts running a little rough and is lacking power. I just replaced my camshaft position sensor And crankshaft position sensor and it didn't help. Any idea what this could be?

Helpppppp!
TallyRacing is offline   Reply With Quote
Old 8/18/11, 10:28 AM   #2
Mach 1 Member
 
Kinyodas's Avatar
 
Byron

Join Date: August 3, 2011
Location: Slidell
Posts: 728
2012 Mustang GT
Did you replace the Coil Packs / Wires / Plugs? I had a 95 Linconl Mark VIII with the 4.6 and the packs started going bad at about 120K and I had to replace the plugs often. I replaced the coil packs at 140K and she ran fine all the way until 225K when I traded her in.
__________________
-Byron

2012 Mustang GT 6M Kona Blue -= As Delivered =-

"A champion is someone who gets up when he can't." - Jack Dempsey

My philosophy learned from life: Time flies, people change.... it floats.
Kinyodas is offline   Reply With Quote
Old 8/18/11, 11:03 AM   #3
BoogieNights Studios:
Official Fluffer
 
BoogieNights's Avatar
 
Dirk

Join Date: September 13, 2009
Location: Clarksville, TN
Posts: 5,286
2004 Chevy 2500HD 4x4
Send a message via Yahoo to BoogieNights
You can also try checking out your MAF sensor too
__________________
Its all fun and games till someone loses a nut!!!!
My website
Member of the "I Hate prius's Club"
Official Boogienights thread here ( Clicky)
___________
/____________\
/_____________ \
( ]]] _ _ O _ _ [[[ )
|\_o _ ____ __ o_/
|
|___|............|___|
BoogieNights is offline   Reply With Quote
Old 8/18/11, 3:24 PM   #4
GT Member
 

Join Date: January 12, 2011
Posts: 150
Check fuel pressure. Could be fuel pump or most likely the fuel filter. People always overlook the fuel filter
Onesickstang01 is offline   Reply With Quote
Old 8/18/11, 7:22 PM   #5
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
What is the MAF? And what are symptoms?
TallyRacing is offline   Reply With Quote
Old 8/18/11, 7:23 PM   #6
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
When you had your Lincoln what did it do? How much did everything cost?
TallyRacing is offline   Reply With Quote
Old 8/18/11, 7:24 PM   #7
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
Would the fuel pump cause the car to shut off tho?
TallyRacing is offline   Reply With Quote
Old 8/18/11, 8:30 PM   #8
 
jacostang's Avatar
 
Dave

Join Date: January 27, 2006
Location: Mesa, AZ
Posts: 3,483
06 LL GT/2011 5.0 Pace Car
Images: 13
Garage
Your going to have to plug her in and see what if any codes are thrown, any auto parts store will have one and they will tell you whats going on....
__________________
Transplanted Pittsburgh Boy In The Desert Sun!!!
"Life's Tough..Even tougher when your stupid".. John Wayne

I Hate Priuses and All Toyotas Coalition. TMS Chapter
jacostang is offline   Reply With Quote
Old 8/18/11, 11:12 PM   #9
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
I did, I went earlier in the week and it said camshaft position sensor, so I replaced that and the crank shaft position sensor, but the car still has the same issues, the light comes back on with the same error code "camshaft position sensor" I'm lost and don't know what else to do!
TallyRacing is offline   Reply With Quote
Old 8/18/11, 11:30 PM   #10
 
jacostang's Avatar
 
Dave

Join Date: January 27, 2006
Location: Mesa, AZ
Posts: 3,483
06 LL GT/2011 5.0 Pace Car
Images: 13
Garage
Well Crap, do you think that one was bad? No other codes... Man I hate throwing parts at problems..
__________________
Transplanted Pittsburgh Boy In The Desert Sun!!!
"Life's Tough..Even tougher when your stupid".. John Wayne

I Hate Priuses and All Toyotas Coalition. TMS Chapter
jacostang is offline   Reply With Quote
Old 8/18/11, 11:47 PM   #11
Member
 
TallyRacing's Avatar
 

Join Date: August 9, 2011
Posts: 22
Yeah man it sucks! I wouldn't think so but who knows! There could be a chance! I hope it's something simple.
TallyRacing is offline   Reply With Quote
Old 8/19/11, 12:44 AM   #12
Member
 
Paul

Join Date: August 17, 2011
Location: Ohio
Posts: 19
2006 Mustang GT
Not sure if your car has a distributor cap, but you might want to check that.
uufbbigpaul75 is offline   Reply With Quote
Old 8/19/11, 12:59 AM   #13
NTTAWWT
 
StangMahn's Avatar
 
David

Join Date: January 27, 2007
Location: That town you drive through to get to Myrtle Beach
Posts: 11,287
04 Sonic Blue GT
Garage
Mine does the exact same thing.

Try to crank it up next time, but pause in the on position (right before cranking), in that spot, it activates the fuel pump and builds some pressure. Mine starts doing that.

Try cleaning your Mass Air Flow sensor and Throttle Body (both very easy, get the right stuff, and search on how to do it).

I haven't nailed it down myself, but I believe it's the fuel pump starting to go.
__________________
2004 40th Anniversary Sonic Blue GT

Founder - I Hate priuses Coalition - TMS Chapter



Quote:
"Mmmm, we have everything we need...scenery, swooping road, no traffic...the Holy Trinity for anyone who's Communion wine comes with an Octane rating. - Jezza
StangMahn is offline   Reply With Quote
Old 8/31/11, 12:18 PM   #14
Mach 1 Member
 
Kinyodas's Avatar
 
Byron

Join Date: August 3, 2011
Location: Slidell
Posts: 728
2012 Mustang GT
Costs

Quote:
Originally Posted by TallyRacing View Post
When you had your Lincoln what did it do? How much did everything cost?
Everything was under $200 for sure - maybe as low as $150.
__________________
-Byron

2012 Mustang GT 6M Kona Blue -= As Delivered =-

"A champion is someone who gets up when he can't." - Jack Dempsey

My philosophy learned from life: Time flies, people change.... it floats.
Kinyodas is offline   Reply With Quote
Old 9/4/11, 9:02 AM   #15
Member
 

Join Date: September 4, 2011
Posts: 2
If you think it's fuel pump, take the intake off that goes to your throttle body and while someone cranks up the car spray carb and choke cleaner in the throttle body if the car runs without shutting off then you most likely have a fuel problem. You're in a really tough position trying to diag this without an IDS from a ford dealership because there are alot of possibilities, it could even be your iac sticking when you start the car. I do agree you have either a fuel or air problem you're just going to need to mess around a bit to pin point the cause.
southsidexers is offline   Reply With Quote
Old 9/9/11, 8:25 PM   #16
Bear Eats King...
Bear ****s Bone
 
texastboneking's Avatar
 
Trent

Join Date: September 5, 2011
Location: Cleburne, Tx
Posts: 3,803
1997 Cobra
Garage
Send a message via Skype™ to texastboneking
Quote:
Originally Posted by TallyRacing
Ok so, I recently bought a 2003 mustang GT and know the car is acting up, when I try to crank it, it will turn on but cut right off, this happens around 3 times then it's fine, it feels like lts running a little rough and is lacking power. I just replaced my camshaft position sensor And crankshaft position sensor and it didn't help. Any idea what this could be?

Helpppppp!
Seen this before. If you haven't figured it out yet.
The hose attached to the fuel pump in the tank can get a small hole in it letting the fuel drain back after you kill it. Making the next start up difficult. I would check the hose.
__________________
1997 Cobra. 2001 Cobra engine swap. BBK fully adjustable suspension, Dynomax exhaust. BBK O/R X-pipe. Full emissions delete (yes that includes evap). 275/35r17 front tires. 315/35r17 rear tires. 3.73 Ford Racing Gears.
texastboneking is offline   Reply With Quote
Old 9/9/11, 8:25 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

Sponsors



 

MotM Winners
December 2012 MotM Winner November 2012 MotM Winner September 2012 MotM Winner August 2012 MotM Winner

All times are GMT -6. The time now is 12:18 PM.


Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.